CVE-2010-4015

NameCVE-2010-4015
DescriptionBuffer overflow in the gettoken function in contrib/intarray/_int_bool.c in the intarray array module in PostgreSQL 9.0.x before 9.0.3, 8.4.x before 8.4.7, 8.3.x before 8.3.14, and 8.2.x before 8.2.20 allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via integers with a large number of digits to unspecified functions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2157-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-8.4 (PTS)wheezy8.4.22-0+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-8.3source(unstable)(unfixed)medium
postgresql-8.3sourcelenny8.3.14-0lenny1mediumDSA-2157-1
postgresql-8.4source(unstable)8.4.7-1medium
postgresql-8.4sourcesqueeze8.4.7-0squeeze2mediumDSA-2157-1
postgresql-9.0source(unstable)9.0.3-1medium

Search for package or bug name: Reporting problems