CVE-2010-4150

NameCVE-2010-4150
DescriptionDouble free vulnerability in the imap_do_open function in the IMAP extension (ext/imap/php_imap.c) in PHP 5.2 before 5.2.15 and 5.3 before 5.3.4 allows attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via unspecified vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2195-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze (security), squeeze5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3-7+squeeze25fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.39-0+deb7u2fixed
jessie, sid5.6.7+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.3.3-7medium
php5sourcelenny5.2.6.dfsg.1-1+lenny10mediumDSA-2195-1
php5sourcesqueeze5.3.3-7+squeeze1mediumDSA-2195-1

Search for package or bug name: Reporting problems