CVE-2010-4252

NameCVE-2010-4252
DescriptionOpenSSL before 1.0.0c, when J-PAKE is enabled, does not properly validate the public parameters in the J-PAKE protocol, which allows remote attackers to bypass the need for knowledge of the shared secret, and successfully authenticate, by sending crafted values in each round of the protocol.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)jessie1.0.1t-1+deb8u8fixed
jessie (security)1.0.1t-1+deb8u9fixed
stretch (security), stretch1.1.0f-3+deb9u2fixed
buster1.1.0h-4fixed
sid1.1.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)(not affected)

Notes

- openssl <not-affected> (configured with -DOPENSSL_NO_JPAKE; bug #606902)
http://www.openssl.org/news/secadv/20101202.txt

Search for package or bug name: Reporting problems