CVE-2010-4262

NameCVE-2010-4262
DescriptionStack-based buffer overflow in Xfig 3.2.4 and 3.2.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a FIG image with a crafted color definition.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs606257

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xfig (PTS)stretch1:3.2.6a-1fixed
buster1:3.2.7a-3fixed
bullseye, sid1:3.2.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xfigsource(unstable)1:3.2.5.b-1.1606257

Notes

details and patch at https://bugzilla.redhat.com/659676

Search for package or bug name: Reporting problems