CVE-2010-4479

NameCVE-2010-4479
DescriptionUnspecified vulnerability in pdf.c in libclamav in ClamAV before 0.96.5 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PDF document, aka "bb #2380," a different vulnerability than CVE-2010-4260.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clamav (PTS)stretch0.102.3+dfsg-0~deb9u1fixed
stretch (security)0.102.4+dfsg-0+deb9u2fixed
buster0.103.3+dfsg-0+deb10u1fixed
bullseye0.103.3+dfsg-0+deb11u1fixed
bookworm, sid0.103.4+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clamavsourcelenny(not affected)
clamavsource(unstable)0.96.5+dfsg-1

Notes

[lenny] - clamav <not-affected> (Introduced in 3643f3d2b0a38fdc7bc6777d093c857b9760804e)
Fixed in 019f1955194360600ecf0644959ceca6734c2d7b

Search for package or bug name: Reporting problems