CVE-2010-4489

NameCVE-2010-4489
Descriptionlibvpx, as used in Google Chrome before 8.0.552.215 and possibly other products, allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted WebM video. NOTE: this vulnerability exists because of a regression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs610510

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)jessie (security), jessie57.0.2987.98-1~deb8u1fixed
stretch62.0.3202.89-1~deb9u1fixed
stretch (security)66.0.3359.117-1~deb9u1fixed
buster, sid67.0.3396.79-2fixed
libvpx (PTS)jessie1.3.0-3fixed
jessie (security)1.3.0-3+deb8u1fixed
stretch (security), stretch1.6.1-3+deb9u1fixed
buster, sid1.7.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)(not affected)
libvpxsource(unstable)0.9.5-1medium610510
libvpxsourcesqueeze(not affected)
webkitsource(unstable)(not affected)

Notes

[squeeze] - libvpx <not-affected> (regression in later version)

Search for package or bug name: Reporting problems