CVE-2010-4536

NameCVE-2010-4536
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in KSES, as used in WordPress before 3.0.4, allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the & (ampersand) character, (2) the case of an attribute name, (3) a padded entity, and (4) an entity that is not in normalized form.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch (security), stretch4.7.5+dfsg-2+deb9u6fixed
buster, buster (security)5.0.10+dfsg1-0+deb10u1fixed
bullseye, sid5.4.2+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
egroupwaresource(unstable)(not affected)
moodlesource(unstable)(not affected)
wordpresssourcelenny(not affected)
wordpresssource(unstable)3.0.4+dfsg-1

Notes

[lenny] - wordpress <not-affected> (2.x version is not affected)
- moodle <not-affected> (Moodle's version of KSES is not affected)
- egroupware <not-affected> (Only uses a minor subset of KSES)

Search for package or bug name: Reporting problems