CVE-2010-4644

NameCVE-2010-4644
DescriptionMultiple memory leaks in rev_hunt.c in Apache Subversion before 1.6.15 allow remote authenticated users to cause a denial of service (memory consumption and daemon crash) via the -g option to the blame command.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
NVD severitylow (attack range: remote)
Debian Bugs608989
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
subversion (PTS)squeeze (security), squeeze1.6.12dfsg-7fixed
squeeze (lts)1.6.12dfsg-7+deb6u1fixed
wheezy, wheezy (security)1.6.17dfsg-4+deb7u8fixed
sid, jessie1.8.10-5fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
subversionsource(unstable)1.6.12dfsg-3low608989

Notes

[lenny] - subversion <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems