CVE-2010-4653

NameCVE-2010-4653
DescriptionAn integer overflow condition in poppler before 0.16.3 can occur when parsing CharCodes for fonts.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)buster0.71.0-5fixed
buster (security)0.71.0-5+deb10u3fixed
bullseye (security), bullseye20.09.0-3.1+deb11u1fixed
bookworm22.12.0-2fixed
sid, trixie24.02.0-5fixed
xpdf (PTS)buster3.04-13fixed
bullseye3.04+git20210103-3fixed
bookworm3.04+git20220601-1fixed
sid, trixie3.04+git20240202-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdegraphicssource(unstable)4:4.0.0-1
popplersourcesqueeze0.12.4-1.2+squeeze1
popplersource(unstable)0.16.3-1low
xpdfsource(unstable)3.02-9

Notes

[lenny] - poppler <no-dsa> (minor issue)
http://cgit.freedesktop.org/poppler/poppler/commit/?id=cad66a7d25abdb6aa15f3aa94a35737b119b2659

Search for package or bug name: Reporting problems