CVE-2010-4654

NameCVE-2010-4654
Descriptionpoppler before 0.16.3 has malformed commands that may cause corruption of the internal stack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)buster0.71.0-5fixed
buster (security)0.71.0-5+deb10u3fixed
bullseye (security), bullseye20.09.0-3.1+deb11u1fixed
bookworm22.12.0-2fixed
sid, trixie24.02.0-5fixed
xpdf (PTS)buster3.04-13fixed
bullseye3.04+git20210103-3fixed
bookworm3.04+git20220601-1fixed
sid, trixie3.04+git20240202-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdegraphicssource(unstable)(not affected)
popplersourcelenny(not affected)
popplersourcesqueeze(not affected)
popplersource(unstable)0.16.3-1
xpdfsource(unstable)(not affected)

Notes

- kdegraphics <not-affected> (no stackheight)
- xpdf <not-affected> (no stackheight)
[lenny] - poppler <not-affected> (stackheights introduced after 0.12)
[squeeze] - poppler <not-affected> (stackheights introduced after 0.12)
http://cgit.freedesktop.org/poppler/poppler/commit/?id=8284008aa8230a92ba08d547864353d3290e9bf9

Search for package or bug name: Reporting problems