Descriptionpoppler before 0.16.3 has malformed commands that may cause corruption of the internal stack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)stretch0.48.0-2+deb9u2fixed
stretch (security)0.48.0-2+deb9u4fixed
bullseye, sid20.09.0-3fixed
xpdf (PTS)stretch3.04-4fixed
sid, buster3.04-13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdegraphicssource(unstable)(not affected)
popplersourcelenny(not affected)
popplersourcesqueeze(not affected)
xpdfsource(unstable)(not affected)


- kdegraphics <not-affected> (no stackheight)
- xpdf <not-affected> (no stackheight)
[lenny] - poppler <not-affected> (stackheights introduced after 0.12)
[squeeze] - poppler <not-affected> (stackheights introduced after 0.12)

Search for package or bug name: Reporting problems