CVE-2010-4657

NameCVE-2010-4657
DescriptionPHP5 before 5.4.4 allows passing invalid utf-8 strings via the xmlTextWriterWriteAttribute, which are then misparsed by libxml2. This results in memory leak into the resulting output.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.4.4-1low

Notes

[squeeze] - php5 <no-dsa> (Minor issue)
https://bugzilla.gnome.org/show_bug.cgi?id=631551
Not sure when this was initially fixed, tested with the initial Wheezy version 5.4.4
and the reproducer from https://bugs.launchpad.net/php/%2Bbug/655442

Search for package or bug name: Reporting problems