CVE-2010-4666

NameCVE-2010-4666
DescriptionBuffer overflow in libarchive 3.0 pre-release code allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted CAB file, which is not properly handled during the reading of Huffman code data within LZX compressed data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs669197

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libarchive (PTS)stretch3.2.2-2+deb9u2fixed
stretch (security)3.2.2-2+deb9u3fixed
buster, buster (security)3.3.3-4+deb10u1fixed
bullseye3.4.3-2+deb11u1fixed
bookworm, sid3.6.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libarchivesourcesqueeze(not affected)
libarchivesource(unstable)3.0.4-2669197

Notes

[squeeze] - libarchive <not-affected> (no cab support prior to 3.0)
http://code.google.com/p/libarchive/source/detail?r=488ef3fb28c416285ebe4c00266268db7330466b
Might be fixed earlier than 3.0.4-2, but was tested against the Wheezy version

Search for package or bug name: Reporting problems