CVE-2010-4704

NameCVE-2010-4704
Descriptionlibavcodec/vorbis_dec.c in the Vorbis decoder in FFmpeg 0.6.1 and earlier allows remote attackers to cause a denial of service (application crash) via a crafted .ogg file, related to the vorbis_floor0_decode function. NOTE: this might overlap CVE-2011-0480.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2165-1, DSA-2306-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs611495
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)squeeze, squeeze (security)4:0.5.10-1fixed
squeeze (lts)4:0.5.10-1+deb6u1fixed
sid7:2.7.1-1fixed
libav (PTS)wheezy6:0.8.16-1fixed
wheezy (security)6:0.8.17-1fixed
jessie6:11.3-1+deb8u1fixed
jessie (security)6:11.4-1~deb8u1fixed
stretch, sid6:11.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.4.1-1low611495
ffmpegsourcesqueeze4:0.5.4-1mediumDSA-2306-1
ffmpeg-debiansource(unstable)(unfixed)medium
ffmpeg-debiansourcelenny0.svn20080206-18+lenny3mediumDSA-2165-1
libavsource(unstable)4:0.6.2-1low611495

Notes

this is a crash found by fuzzing and not clearly exploitable (can be combined with other fixes so low urgency)

Search for package or bug name: Reporting problems