CVE-2010-4705

NameCVE-2010-4705
DescriptionInteger overflow in the vorbis_residue_decode_internal function in libavcodec/vorbis_dec.c in the Vorbis decoder in FFmpeg, possibly 0.6, has unspecified impact and remote attack vectors, related to the sizes of certain integer data types. NOTE: this might overlap CVE-2011-0480.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2165-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot known to be vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)squeeze, squeeze (security)4:0.5.10-1fixed
squeeze (lts)4:0.5.10-1+deb6u1fixed
stretch, sid7:2.7.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)(not affected)
ffmpeg-debiansource(unstable)(unfixed)high
ffmpeg-debiansourcelenny0.svn20080206-18+lenny3highDSA-2165-1

Notes

- ffmpeg <not-affected> (issue introduced in 0.6.x series; bug #611495)
recheck when 0.6.x gets uploaded

Search for package or bug name: Reporting problems