CVE-2011-0014

NameCVE-2011-0014
Descriptionssl/t1_lib.c in OpenSSL 0.9.8h through 0.9.8q and 1.0.0 through 1.0.0c allows remote attackers to cause a denial of service (crash), and possibly obtain sensitive information in applications that use OpenSSL, via a malformed ClientHello handshake message that triggers an out-of-bounds memory access, aka "OCSP stapling vulnerability."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2162-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)wheezy1.0.1e-2+deb7u20fixed
wheezy (security)1.0.1t-1+deb7u3fixed
jessie (security), jessie1.0.1t-1+deb8u7fixed
stretch (security), stretch1.1.0f-3+deb9u1fixed
buster, sid1.1.0g-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsource(unstable)0.9.8o-5low
opensslsourcelenny(not affected)
opensslsourcesqueeze0.9.8o-4squeeze1mediumDSA-2162-1

Notes

[lenny] - openssl <not-affected> (Only 0.9.8h through 0.9.8q are affected)

Search for package or bug name: Reporting problems