DescriptionMultiple heap-based buffer overflows in cdg.c in the CDG decoder in VideoLAN VLC Media Player before 1.1.6 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted CDG video.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)wheezy, wheezy (security)2.0.3-5+deb7u2fixed
jessie (security), jessie2.2.7-1~deb8u1fixed
stretch (security), stretch2.2.7-1~deb9u1fixed
buster, sid3.0.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsourcelenny(not affected)


[lenny] - vlc <not-affected> (Vulnerable code not present);a=commit;h=f9b664eac0e1a7bceed9d7b5854fd9fc351b4aab

Search for package or bug name: Reporting problems