CVE-2011-0419

NameCVE-2011-0419
DescriptionStack consumption vulnerability in the fnmatch implementation in apr_fnmatch.c in the Apache Portable Runtime (APR) library before 1.4.3 and the Apache HTTP Server before 2.2.18, and in fnmatch.c in libc in NetBSD 5.1, OpenBSD 4.8, FreeBSD, Apple Mac OS X 10.6, Oracle Solaris 10, and Android, allows context-dependent attackers to cause a denial of service (CPU and memory consumption) via *? sequences in the first argument, as demonstrated by attacks against mod_autoindex in httpd.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2237-2
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apr (PTS)wheezy1.4.6-3+deb7u1fixed
wheezy (security)1.4.6-3+deb7u2fixed
jessie1.5.1-3fixed
stretch1.5.2-5fixed
buster, sid1.6.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aprsource(unstable)1.4.4-1low
aprsourcelenny1.2.12-5+lenny4mediumDSA-2237-2
aprsourcesqueeze1.4.2-6+squeeze2mediumDSA-2237-2

Search for package or bug name: Reporting problems