CVE-2011-0427

NameCVE-2011-0427
DescriptionHeap-based buffer overflow in Tor before 0.2.1.29 and 0.2.2.x before 0.2.2.21-alpha allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via unspecified vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2148-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tor (PTS)squeeze, squeeze (security)0.2.2.39-1fixed
squeeze (lts)0.2.4.27-1~deb6u1fixed
wheezy0.2.4.24-1fixed
wheezy (security)0.2.4.27-1fixed
jessie0.2.5.12-1fixed
stretch, sid0.2.6.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
torsource(unstable)0.2.1.29-1medium
torsourcelenny0.2.1.29-1~lenny+1mediumDSA-2148-1

Search for package or bug name: Reporting problems