CVE-2011-0538

NameCVE-2011-0538
DescriptionWireshark 1.2.0 through 1.2.14, 1.4.0 through 1.4.3, and 1.5.0 frees an uninitialized pointer during processing of a .pcap file in the pcap-ng format, which allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via a malformed file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-2201-1
Debian Bugs613202

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)buster2.6.20-0+deb10u4fixed
buster (security)2.6.20-0+deb10u2fixed
bullseye (security), bullseye3.4.10-0+deb11u1fixed
bookworm, sid4.0.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourcelenny1.0.2-3+lenny13DSA-2201-1
wiresharksourcesqueeze1.2.11-6+squeeze1DSA-2201-1
wiresharksource(unstable)1.4.3-3low613202

Search for package or bug name: Reporting problems