CVE-2011-0697

NameCVE-2011-0697
DescriptionCross-site scripting (XSS) vulnerability in Django 1.1.x before 1.1.4 and 1.2.x before 1.2.5 might allow remote attackers to inject arbitrary web script or HTML via a filename associated with a file upload.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-2163-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)bullseye (security), bullseye2:2.2.28-1~deb11u2fixed
bookworm, bookworm (security)3:3.2.19-1+deb12u1fixed
sid, trixie3:4.2.14-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosourcelenny(not affected)
python-djangosourcesqueeze1.2.3-3+squeeze1
python-djangosource(unstable)1.2.5-1

Notes

[lenny] - python-django <not-affected> (Vulnerable code not present)
http://www.djangoproject.com/weblog/2011/feb/08/security/

Search for package or bug name: Reporting problems