CVE-2011-0707

NameCVE-2011-0707
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in Cgi/confirm.py in GNU Mailman 2.1.14 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) full name or (2) username field in a confirmation message.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2170-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mailman (PTS)squeeze (security), squeeze1:2.1.13-5fixed
squeeze (lts)1:2.1.13-6fixed
wheezy1:2.1.15-1fixed
wheezy (security)1:2.1.15-1+deb7u1fixed
jessie, sid1:2.1.18-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mailmansource(unstable)1:2.1.14-1medium
mailmansourcelenny1:2.1.11-11+lenny2mediumDSA-2170-1
mailmansourcesqueeze1:2.1.13-5mediumDSA-2170-1

Notes

patch http://mail.python.org/pipermail/mailman-developers/attachments/20110218/15500b22/attachment.txt
present in 2.1.14 and earlier
http://mail.python.org/pipermail/mailman-developers/2011-February/021317.html

Search for package or bug name: Reporting problems