CVE-2011-0721

NameCVE-2011-0721
DescriptionMultiple CRLF injection vulnerabilities in (1) chfn and (2) chsh in shadow 1:4.1.4 allow local users to add new users or groups to /etc/passwd via the GECOS field.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2164-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
shadow (PTS)wheezy1:4.1.5.1-1fixed
wheezy (security)1:4.1.5.1-1+deb7u1fixed
jessie (security), jessie1:4.2-3+deb8u4fixed
stretch1:4.4-4.1fixed
buster, sid1:4.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
shadowsource(unstable)1:4.1.4.2+svn3283-3medium
shadowsourcelenny(not affected)
shadowsourcesqueeze1:4.1.4.2+svn3283-2+squeeze1mediumDSA-2164-1

Notes

[lenny] - shadow <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems