CVE-2011-0992

NameCVE-2011-0992
DescriptionUse-after-free vulnerability in Mono, when Moonlight 2.x before 2.4.1 or 3.x before 3.99.3 is used, allows remote attackers to cause a denial of service (plugin crash) or obtain sensitive information via vectors related to member data in a resurrected MonoThread instance.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mono (PTS)buster5.18.0.240+dfsg-3fixed
buster (security)5.18.0.240+dfsg-3+deb10u1fixed
bullseye6.8.0.105+dfsg-3.3~deb11u1fixed
bookworm6.8.0.105+dfsg-3.3fixed
trixie, sid6.8.0.105+dfsg-3.6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
monosource(unstable)(not affected)

Notes

- mono <not-affected> (Moonlight no longer present in Debian)

Search for package or bug name: Reporting problems