CVE-2011-1006

NameCVE-2011-1006
DescriptionHeap-based buffer overflow in the parse_cgroup_spec function in tools/tools-common.c in the Control Group Configuration Library (aka libcgroup or libcg) before 0.37.1 allows local users to gain privileges via a crafted controller list on the command line of an application. NOTE: it is not clear whether this issue crosses privilege boundaries.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2193-1
NVD severityhigh (attack range: local)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcgroup (PTS)squeeze (security), squeeze0.36.2-3+squeeze1fixed
wheezy0.38-1fixed
jessie, sid0.41-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcgroupsource(unstable)0.37.1-1high
libcgroupsourcesqueeze0.36.2-3+squeeze1highDSA-2193-1

Search for package or bug name: Reporting problems