CVE-2011-1017

NameCVE-2011-1017
DescriptionHeap-based buffer overflow in the ldm_frag_add function in fs/partitions/ldm.c in the Linux kernel 2.6.37.2 and earlier might allow local users to gain privileges or obtain sensitive information via a crafted LDM partition table.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2240-1, DSA-2264-1
NVD severityhigh (attack range: local)

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linux-2.6source(unstable)2.6.38-5high
linux-2.6sourcelenny2.6.26-26lenny3highDSA-2264-1
linux-2.6sourcesqueeze2.6.32-34squeeze1highDSA-2240-1

Search for package or bug name: Reporting problems