CVE-2011-1023

NameCVE-2011-1023
DescriptionThe Reliable Datagram Sockets (RDS) subsystem in the Linux kernel before 2.6.38 does not properly handle congestion map updates, which allows local users to cause a denial of service (BUG_ON and system crash) via vectors involving (1) a loopback (aka loop) transmit operation or (2) an InfiniBand (aka ib) transmit operation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linux-2.6sourcelenny(not affected)
linux-2.6sourcesqueeze(not affected)
linux-2.6source(unstable)2.6.38-1

Notes

[squeeze] - linux-2.6 <not-affected> (Introduced in 2.6.35)
[lenny] - linux-2.6 <not-affected> (Introduced in 2.6.35)

Search for package or bug name: Reporting problems