CVE-2011-1058

NameCVE-2011-1058
DescriptionCross-site scripting (XSS) vulnerability in the reStructuredText (rst) parser in parser/text_rst.py in MoinMoin before 1.9.3, when docutils is installed or when "format rst" is set, allows remote attackers to inject arbitrary web script or HTML via a javascript: URL in the refuri attribute. NOTE: some of these details are obtained from third party information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2321-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
moin (PTS)wheezy1.9.4-8+deb7u2fixed
wheezy (security)1.9.4-8+deb7u3fixed
jessie (security), jessie1.9.8-1+deb8u1fixed
buster, sid, stretch1.9.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
moinsource(unstable)1.9.3-3low
moinsourcelenny1.7.1-3+lenny6lowDSA-2321-1
moinsourcesqueeze1.9.3-1+squeeze1lowDSA-2321-1

Search for package or bug name: Reporting problems