CVE-2011-1087

NameCVE-2011-1087
DescriptionBuffer overflow in VideoLAN VLC media player 1.0.5 allows user-assisted remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via a crafted .mp3 file that is played during bookmark creation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs616156

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)wheezy, wheezy (security)2.0.3-5+deb7u2fixed
jessie (security), jessie2.2.6-1~deb8u1fixed
stretch2.2.6-1~deb9u1fixed
buster, sid2.2.6-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)1.1.10-1low616156

Notes

[squeeze] - vlc <no-dsa> (Minor issue)
[lenny] - vlc <no-dsa> (Minor issue)
http://www.zeroscience.mk/en/vulnerabilities/ZSL-2010-4931.php
obscure exploit scenario

Search for package or bug name: Reporting problems