CVE-2011-1090

NameCVE-2011-1090
DescriptionThe __nfs4_proc_set_acl function in fs/nfs/nfs4proc.c in the Linux kernel before 2.6.38 stores NFSv4 ACL data in memory that is allocated by kmalloc but not properly freed, which allows local users to cause a denial of service (panic) via a crafted attempt to set an ACL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2240-1, DSA-2264-1
NVD severitymedium (attack range: local)

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linux-2.6source(unstable)2.6.38-1low
linux-2.6sourcelenny2.6.26-26lenny3mediumDSA-2264-1
linux-2.6sourcesqueeze2.6.32-34squeeze1mediumDSA-2240-1

Search for package or bug name: Reporting problems