CVE-2011-1097

NameCVE-2011-1097
Descriptionrsync 3.x before 3.0.8, when certain recursion, deletion, and ownership options are used, allows remote rsync servers to cause a denial of service (heap memory corruption and application crash) or possibly execute arbitrary code via malformed data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs621866

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rsync (PTS)stretch3.1.2-1+deb9u2fixed
stretch (security)3.1.2-1+deb9u1fixed
buster3.1.3-6fixed
bullseye, sid3.2.3-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rsyncsource(unstable)3.0.8low621866

Notes

[squeeze] - rsync <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems