CVE-2011-1137

NameCVE-2011-1137
DescriptionInteger overflow in the mod_sftp (aka SFTP) module in ProFTPD 1.3.3d and earlier allows remote attackers to cause a denial of service (memory consumption leading to OOM kill) via a malformed SSH message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2185-1
NVD severitymedium (attack range: remote)
Debian Bugs616179

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
proftpd-dfsg (PTS)wheezy, wheezy (security)1.3.4a-5+deb7u3fixed
jessie1.3.5-1.1+deb8u2fixed
jessie (security)1.3.5-1.1+deb8u1fixed
stretch1.3.5b-4fixed
buster, sid1.3.5d-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
proftpd-dfsgsource(unstable)1.3.3d-4medium616179
proftpd-dfsgsourcelenny(not affected)
proftpd-dfsgsourcesqueeze1.3.3a-6squeeze1mediumDSA-2185-1

Notes

[lenny] - proftpd-dfsg <not-affected> (Vulnerable code not present)
http://bugs.proftpd.org/show_bug.cgi?id=3586
http://www.exploit-db.com/exploits/16129/

Search for package or bug name: Reporting problems