CVE-2011-1153

NameCVE-2011-1153
DescriptionMultiple format string vulnerabilities in phar_object.c in the phar extension in PHP 5.3.5 and earlier allow context-dependent attackers to obtain sensitive information from process memory, cause a denial of service (memory corruption), or possibly execute arbitrary code via format string specifiers in an argument to a class method, leading to an incorrect zend_throw_exception_ex call.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2266-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3.1-7+squeeze26fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.41-0+deb7u1fixed
jessie5.6.7+dfsg-1fixed
jessie (security)5.6.9+dfsg-0+deb8u1fixed
stretch, sid5.6.9+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.3.6-1unimportant
php5sourcelenny5.2.6.dfsg.1-1+lenny12highDSA-2266-1
php5sourcesqueeze5.3.3-7+squeeze3highDSA-2266-1

Notes

only exploitable by malicious scripts

Search for package or bug name: Reporting problems