CVE-2011-1168

NameCVE-2011-1168
DescriptionCross-site scripting (XSS) vulnerability in the KHTMLPart::htmlError function in khtml/khtml_part.cpp in Konqueror in KDE SC 4.4.0 through 4.6.1 allows remote attackers to inject arbitrary web script or HTML via the URI in a URL corresponding to an unavailable web site.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kde4libs (PTS)jessie4:4.14.2-5+deb8u2fixed
jessie (security)4:4.14.2-5+deb8u3fixed
stretch4:4.14.26-2fixed
buster4:4.14.38-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kde4libssource(unstable)4:4.4.5-4low
kde4libssourcesqueeze4:4.4.5-2+squeeze2

Notes

[lenny] - kde4libs <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems