CVE-2011-1169

NameCVE-2011-1169
DescriptionArray index error in the asihpi_hpi_ioctl function in sound/pci/asihpi/hpioctl.c in the AudioScience HPI driver in the Linux kernel before 2.6.38.1 might allow local users to cause a denial of service (memory corruption) or possibly gain privileges via a crafted adapter index value that triggers access to an invalid kernel pointer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linux-2.6sourcelenny(not affected)
linux-2.6sourcesqueeze(not affected)
linux-2.6source(unstable)2.6.38-2

Notes

[lenny] - linux-2.6 <not-affected> (Introduced in 2.6.35)
[squeeze] - linux-2.6 <not-affected> (Introduced in 2.6.35)

Search for package or bug name: Reporting problems