CVE-2011-1178

NameCVE-2011-1178
DescriptionMultiple integer overflows in the load_image function in file-pcx.c in the Personal Computer Exchange (PCX) plugin in GIMP 2.6.x and earlier allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PCX image that triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gimp (PTS)stretch (security), stretch2.8.18-1+deb9u1fixed
buster2.10.8-2fixed
bullseye2.10.22-4fixed
bookworm, sid2.10.30-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gimpsource(unstable)2.6.10-1

Notes

Likely fixed earlier, but only the squeeze version was checked

Search for package or bug name: Reporting problems