CVE-2011-1398

NameCVE-2011-1398
DescriptionThe sapi_header_op function in main/SAPI.c in PHP before 5.3.11 and 5.4.x before 5.4.0RC2 does not check for %0D sequences (aka carriage return characters), which allows remote attackers to bypass an HTTP response-splitting protection mechanism via a crafted URL, related to improper interaction between the PHP header function and certain browsers, as demonstrated by Internet Explorer and Google Chrome.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
NVD severitymedium (attack range: remote)
Debian/oldoldstablepackage php5 is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19vulnerable
squeeze (lts)5.3.3.1-7+squeeze26vulnerable
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.44-0+deb7u1fixed
jessie5.6.7+dfsg-1fixed
jessie (security)5.6.12+dfsg-0+deb8u1fixed
stretch5.6.11+dfsg-1fixed
sid5.6.12+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.4.0~rc5-1low

Notes

[squeeze] - php5 <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems