CVE-2011-1407

NameCVE-2011-1407
DescriptionThe DKIM implementation in Exim 4.7x before 4.76 permits matching for DKIM identities to apply to lookup items, instead of only strings, which allows remote attackers to execute arbitrary code or access a filesystem via a crafted identity.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2236-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)squeeze4.72-6+squeeze4fixed
squeeze (security)4.72-6+squeeze3fixed
wheezy4.80-7+deb7u1fixed
jessie4.84-8fixed
stretch, sid4.85-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exim4source(unstable)4.76-1high
exim4sourcelenny(not affected)
exim4sourcesqueeze4.72-6+squeeze2highDSA-2236-1

Notes

[lenny] - exim4 <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems