CVE-2011-1411

NameCVE-2011-1411
DescriptionShibboleth OpenSAML library 2.4.x before 2.4.3 and 2.5.x before 2.5.1, and IdP before 2.3.2, allows remote attackers to forge messages and bypass authentication via an "XML Signature wrapping attack."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2284-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opensaml2 (PTS)wheezy2.4.3-4+deb7u1fixed
wheezy (security)2.4.3-4+deb7u2fixed
jessie (security), jessie2.5.3-2+deb8u2fixed
stretch (security), stretch2.6.0-4+deb9u1fixed
buster, sid2.6.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensaml2source(unstable)2.4.3-1medium
opensaml2sourcelenny2.0-2+lenny3mediumDSA-2284-1
opensaml2sourcesqueeze2.3-2+squeeze1mediumDSA-2284-1

Search for package or bug name: Reporting problems