CVE-2011-1485

NameCVE-2011-1485
DescriptionRace condition in the pkexec utility and polkitd daemon in PolicyKit (aka polkit) 0.96 allows local users to gain privileges by executing a setuid program from pkexec, related to the use of the effective user ID instead of the real user ID.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2319-1
NVD severitymedium (attack range: local)
Debian Bugs644500

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
policykit-1 (PTS)wheezy0.105-3fixed
jessie0.105-15~deb8u2fixed
buster, sid, stretch0.105-18fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
policykit-1source(unstable)0.101-4medium644500
policykit-1sourcesqueeze0.96-4+squeeze1mediumDSA-2319-1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=692922

Search for package or bug name: Reporting problems