CVE-2011-1486

NameCVE-2011-1486
Descriptionlibvirtd in libvirt before 0.9.0 does not use thread-safe error reporting, which allows remote attackers to cause a denial of service (crash) by causing multiple threads to report errors at the same time.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2280-1
NVD severitylow (attack range: remote)
Debian Bugs623222
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvirt (PTS)squeeze, squeeze (security)0.8.3-5+squeeze5fixed
wheezy (security), wheezy0.9.12.3-1+deb7u1fixed
jessie1.2.9-9fixed
stretch, sid1.2.18-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvirtsource(unstable)0.9.0-1low623222
libvirtsourcelenny0.4.6-10+lenny2lowDSA-2280-1
libvirtsourcesqueeze0.8.3-5+squeeze2lowDSA-2280-1

Notes

[lenny] - libvirt <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems