CVE-2011-1492

NameCVE-2011-1492
Descriptionsteps/utils/modcss.inc in Roundcube Webmail before 0.5.1 does not properly verify that a request is an expected request for an external Cascading Style Sheets (CSS) stylesheet, which allows remote authenticated users to trigger arbitrary outbound TCP connections from the server, and possibly obtain sensitive information, via a crafted request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
roundcube (PTS)stretch1.2.3+dfsg.1-4+deb9u6fixed
stretch (security)1.2.3+dfsg.1-4+deb9u10fixed
buster, buster (security)1.3.17+dfsg.1-1~deb10u2fixed
bullseye (security), bullseye1.4.13+dfsg.1-1~deb11u1fixed
sid1.5.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
roundcubesource(unstable)0.5.1-1

Notes

[squeeze] - roundcube <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems