CVE-2011-1507

NameCVE-2011-1507
DescriptionAsterisk Open Source 1.4.x before 1.4.40.1, 1.6.1.x before 1.6.1.25, 1.6.2.x before 1.6.2.17.3, and 1.8.x before 1.8.3.3 and Asterisk Business Edition C.x.x before C.3.6.4 do not restrict the number of unauthenticated sessions to certain interfaces, which allows remote attackers to cause a denial of service (file descriptor exhaustion and disk space exhaustion) via a series of TCP connections.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2225-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)wheezy1:1.8.13.1~dfsg1-3+deb7u3fixed
wheezy (security)1:1.8.13.1~dfsg1-3+deb7u7fixed
jessie1:11.13.1~dfsg-2+deb8u2fixed
jessie (security)1:11.13.1~dfsg-2+deb8u4fixed
stretch1:13.14.1~dfsg-2+deb9u1fixed
stretch (security)1:13.14.1~dfsg-2+deb9u2fixed
buster, sid1:13.17.2~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksource(unstable)1:1.8.3.3-1medium
asterisksourcelenny1:1.4.21.2~dfsg-3+lenny2.1mediumDSA-2225-1
asterisksourcesqueeze1:1.6.2.9-2+squeeze2mediumDSA-2225-1

Search for package or bug name: Reporting problems