CVE-2011-1522

NameCVE-2011-1522
DescriptionMultiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2223-1
NVD severityhigh (attack range: remote)
Debian Bugs622674

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
doctrine (PTS)wheezy1.2.4-1fixed
jessie2.4.6-1+deb8u1fixed
stretch2.5.4+dfsg-2fixed
buster, sid2.5.11+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
doctrinesource(unstable)1.2.4-1high622674
doctrinesourcesqueeze1.2.2-2+squeeze1highDSA-2223-1

Search for package or bug name: Reporting problems