CVE-2011-1527

NameCVE-2011-1527
DescriptionThe kdb_ldap plugin in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.9 through 1.9.1, when the LDAP back end is used, allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a kinit operation with incorrect string case for the realm, related to the is_principal_in_realm, krb5_set_error_message, krb5_ldap_get_principal, and process_as_req functions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs646367

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)buster1.17-3+deb10u3fixed
buster (security)1.17-3+deb10u2fixed
bullseye1.18.3-6+deb11u1fixed
bookworm, sid1.20-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5sourcelenny(not affected)
krb5sourcesqueeze(not affected)
krb5source(unstable)1.10+dfsg~alpha1-1low646367

Notes

[squeeze] - krb5 <not-affected> (Introduced in 1.9)
[lenny] - krb5 <not-affected> (Introduced in 1.9)

Search for package or bug name: Reporting problems