CVE-2011-1553

NameCVE-2011-1553
DescriptionUse-after-free vulnerability in t1lib 5.1.2 and earlier, as used in Xpdf before 3.02pl6, teTeX, and other products, allows remote attackers to cause a denial of service (application crash) via a PDF document containing a crafted Type 1 font that triggers an invalid memory write, a different vulnerability than CVE-2011-0764.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2388-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)wheezy0.18.4-6fixed
wheezy (security)0.18.4-6+deb7u1fixed
jessie (security), jessie0.26.5-2+deb8u1fixed
stretch, sid0.48.0-2fixed
t1lib (PTS)wheezy5.1.2-3.6fixed
xpdf (PTS)wheezy3.03-10fixed
jessie3.03-17fixed
stretch, sid3.04-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)(not affected)
t1libsource(unstable)5.1.2-3.5medium
t1libsourcelenny5.1.2-3+lenny1medium
t1libsourcesqueeze5.1.2-3+squeeze1medium
xpdfsource(unstable)3.02-9medium

Notes

see https://bugzilla.redhat.com/show_bug.cgi?id=692909#c23
- poppler <not-affected> (never used t1lib)

Search for package or bug name: Reporting problems