CVE-2011-1554

NameCVE-2011-1554
DescriptionOff-by-one error in t1lib 5.1.2 and earlier, as used in Xpdf before 3.02pl6, teTeX, and other products, allows remote attackers to cause a denial of service (application crash) via a PDF document containing a crafted Type 1 font that triggers an invalid memory read, integer overflow, and invalid pointer dereference, a different vulnerability than CVE-2011-0764.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2388-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)squeeze, squeeze (security)0.12.4-1.2+squeeze3fixed
squeeze (lts)0.12.4-1.2+squeeze4fixed
wheezy0.18.4-6fixed
stretch, sid, jessie0.26.5-2fixed
t1lib (PTS)squeeze, squeeze (security)5.1.2-3+squeeze1fixed
wheezy5.1.2-3.6fixed
xpdf (PTS)squeeze3.02-12+squeeze1fixed
wheezy3.03-10fixed
stretch, sid, jessie3.03-17fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)(not affected)
t1libsource(unstable)5.1.2-3.5medium
t1libsourcelenny5.1.2-3+lenny1medium
t1libsourcesqueeze5.1.2-3+squeeze1medium
xpdfsource(unstable)3.02-9medium

Notes

see https://bugzilla.redhat.com/show_bug.cgi?id=692909#c23
- poppler <not-affected> (never used t1lib)

Search for package or bug name: Reporting problems