DescriptionStack-based buffer overflow in the DECT dissector in epan/dissectors/packet-dect.c in Wireshark 1.4.x before 1.4.5 allows remote attackers to execute arbitrary code via a crafted .pcap file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)stretch (security), stretch2.6.7-1~deb9u1fixed
bullseye, sid3.2.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourcelenny(not affected)
wiresharksourcesqueeze(not affected)


[squeeze] - wireshark <not-affected> (Only affects 1.4.x)
[lenny] - wireshark <not-affected> (Only affects 1.4.x)

Search for package or bug name: Reporting problems