CVE-2011-1657

NameCVE-2011-1657
DescriptionThe (1) ZipArchive::addGlob and (2) ZipArchive::addPattern functions in ext/zip/php_zip.c in PHP 5.3.6 allow context-dependent attackers to cause a denial of service (application crash) via certain flags arguments, as demonstrated by (a) GLOB_ALTDIRFUNC and (b) GLOB_APPEND.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2408-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablepackage php5 is vulnerable.
Debian/testingpackage php5 is vulnerable.
Debian/unstablepackage php5 is vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze (security), squeeze5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3-7+squeeze25fixed
wheezy5.4.36-0+deb7u1vulnerable
wheezy (security)5.4.39-0+deb7u2vulnerable
jessie5.6.6+dfsg-2vulnerable
sid5.6.7+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)unimportant
php5sourcesqueeze5.3.3-7+squeeze8mediumDSA-2408-1

Notes

safe mode not supported

Search for package or bug name: Reporting problems