CVE-2011-1659

NameCVE-2011-1659
DescriptionInteger overflow in posix/fnmatch.c in the GNU C Library (aka glibc or libc6) 2.13 and earlier allows context-dependent attackers to cause a denial of service (application crash) via a long UTF8 string that is used in an fnmatch call with a crafted pattern argument, a different vulnerability than CVE-2011-1071.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10fixed
wheezy (security)2.13-38+deb7u12fixed
glibc (PTS)jessie2.19-18+deb8u9fixed
jessie (security)2.19-18+deb8u10fixed
stretch2.24-11fixed
stretch (security)2.24-11+deb9u1fixed
buster, sid2.24-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)2.13-8medium
eglibcsourcesqueeze2.11.3-2medium
glibcsource(unstable)2.13-8medium

Notes

[lenny] - glibc <no-dsa> (Minor issue)
http://sourceware.org/git/?p=glibc.git;a=commitdiff;h=8126d90480fa

Search for package or bug name: Reporting problems