CVE-2011-1753

NameCVE-2011-1753
Descriptionexpat_erl.c in ejabberd before 2.1.7 and 3.x before 3.0.0-alpha-3, and exmpp before 0.9.7, does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2248-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ejabberd (PTS)wheezy2.1.10-4+deb7u1fixed
wheezy (security)2.1.10-4+deb7u2fixed
jessie14.07-4+deb8u3fixed
stretch16.09-4fixed
buster, sid17.08-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ejabberdsource(unstable)2.1.6-2.1medium
ejabberdsourcelenny2.0.1-6+lenny3mediumDSA-2248-1
ejabberdsourcesqueeze2.1.5-3+squeeze1mediumDSA-2248-1

Search for package or bug name: Reporting problems